0
Answered

Transparency

Benoit St-Jean 4 months ago updated by Vitaly Ovchinnikov 4 months ago 10

Hi Vitaly,

When I do a mask on my texture art to have holes or a certain shape, those part are not completely transparent.

Is there a trick to correct this (this is common to Boxshot 4 and 5).

Thanks

Answer

+1
Answer
Answered

Try setting a reflection mask that matches the main texture transparency.

GOOD, I'M SATISFIED
Satisfaction mark by Benoit St-Jean 4 months ago
+1
Answer
Answered

Try setting a reflection mask that matches the main texture transparency.

It is better with the reflection mask, but still not good.

First screenshot: in Boxshot preview it doesn't show

Second screenshot: still show on final render.

Under review

Did you apply the mask to both sides? If yes, please share the project so I can have a closer look.

+1

Also, OpenGL preview does not 100% match the final output (although we try our best to do so), so please use the raytracing preview to check what you get after rendering.

I just tried to applied it to both sides, it is a lot better but there still something wrong at the top corners.

I'm giving you my files so that you can look at this and tell me if I'm doing this right.

Check "Thin Object" box for both front and back side materials. This turns off refraction and combined with reflection mask should give you the expected result.

I just tried the "Thin Object" box and the result still not perfect, there still two notches at the top of the package.

Overall it is a lot better from where I started and that small defect will be easy to correct in Photoshop.

Thanks for the usual great help.

This looks like UV wrapping for me, there is a box for that, too.

I did played with the UV wrapping, but with no good result.

Cheers !

Answered

The UV wrapping should be turned off for this shape, but the main problem is with the texture mapping here:

You may see the top right corner of the bag with your artwork applied. I removed the reflection mask, so the corner is more visible. As you see, the top left part of the corner curve goes up with the geometry and you see the artifact.

The solution (not sure if it is acceptable though) is to adjust the corner curve slightly, so it stays a little bit more away from the corner. Just move the control point a couple of millimetres left. This should do the job. You can temporary apply a more detailed texture there to see what exactly part goes up, so you can the adjust the curve accordingly.

Cheers!