0
Answered

Need Help: Texture / Decal not working properly

Chris B 3 months ago updated by Vitaly Ovchinnikov 3 months ago 9

I am creating a product shot for wrapping paper. For the paper itself, I created a stroke that wraps around the cardboard tube, and then extruded the stoke the same length as the tube (66cm)

The design that is supposed to fit on the paper is 66cm wide @ 150DPI and should fit exactly on the paper at 100%.

When I try to put the paper design on the paper as a texture, I get two different errors:

UV Mapping on: The paper design repeats, but I only need it to appear once.

UV Mapping off: The image is tiny and stretches the edge color the length of the tube

When I try to put the paper design on the paper as a decal, I get one error:

The design seems to be working correctly, but only a portion of the designs appears (I made the paper grey in the enclosed example so you can see what part is getting covered) and the programs seems to bog down.

EXAMPLE OF ERRORS:

My assumption is that maybe the image file is too large to wrap?  Is there anything I am missing?

Thanks for your help!

-Chris

Under review

Hello Chris,

That surface is probably quite complex/large for using a decal, so I would go with the texture mapping instead. Apply the image as a texture, disable the uv wrapping (as you don't need that) and use UV scale and offset parameters to match the image and surface. It shouldn't take long.

Also, it would be nice if you can share some renderings for our gallery please. I like the scene :)

Cheers!

Missing labelI was able to do it as you suggested, although the UV scale sliders were very difficult to find the correct values.

I have tried to add a product decal to the tube of wrapping paper, and I am having the same problem where a large section of the art is missing. The decal file is a pdf.


Can you help me figure out why it isn't displaying correctly?

Missing label

Not sure about the missing label that I suggested, could you clarify please?

Overall, decals are designed to be used like "local" stickers, not the wrap-around ones. If you need to apply a small element somewhere - decal is the way to go, otherwise you need to use textures. It would help if you provide more information on what exactly you are trying to achieve at the second step.

PS: I've added a simpler side mapping option for the extrude shape into our todo list.

Here is another image of the decal error. Not all of the decal is displaying. Enclosed is an image of the decal place on the tube (I made the tube brown so you could see the decal better) as well as an image of the entire decal. As you can see, only the bottom portion of the decal is visible and then, above the UPC code, it gets glitchy. If I try to move the decal to a different location, different parts of the decal will be missing. 

wrapping_label_error.png

Can you share the whole project, please? With all the artwork etc. You can do this privately, if you like.

Answered

Try reducing the curve smoothness level of the paper roll to something about 75%. It looks like the mesh of the paper roll becomes too detailed, so the decal fails to apply to it properly. Reducing the level of details helps without any visible issues to the main shape.

I have another issue: I am trying to create an open box (in this case, it is a slide-out drawer style box. I tried making one side of the box transparent (0% opacity), but when I render, that side of the box is solid black.

How can I get it to render like it appears in the model?

open box image

Try checking "Split inner geometry" box and then make the "Inside Front" material transparent, as well. Do not forget to set both Front and Inside Front materials to metallic and reduce the reflection to 0%.