0
Not a bug

Origami will not render when shown on multiple monitors

Claus 2 years ago updated by Vitaly Ovchinnikov 2 years ago 5

When running Origami 2.8.1 with Illustrator CC 2018 on a machine with multiple displays (a total of 3 screens), the rendering and sortware makes a lot of wierd stuff and you cannot rotate the model - the viewer just freezes.

When set back to 1 screen, the software works again - and the input given by the mouse has been registrated.


It worked perfectly in CC 2017 with version 2.5 and 2.6.


I experience that illustrator has a hard time when GPU is turned on - so I just use CPU-rendering. Could it be a simular setting inside Origami - I see no possibiliti to control the usage of GPU and CPU-render in the Origami option controls.

Under review

Hello Claus,

Does it happen to preview or to the rendering itself, like when you click "Save image" or "Copy image" buttons in toolbar?

Also what operating system you use?

Cheers!

Hi,

It happens during preview - - I cannot click the rendering buttons, as the full window (frame) is frozen. If i unplug the other screens the window unfreezes and can continue to work.


I use 64 bit Windows 10 Enterprise (version 1709 - OS build 16299.726).


Br. Claus

Assuming that you have the latest drivers for all the hardware, try switching OpenGL driver in Origami settings. Start with the "Software" one and see if it helps. Then you can try other hardware-accelerated ones to see if they work better.

I would also like to see the origami_log.txt from the system folder (can be opened from the Help menu). Feel free to send it privately or post it here.

Hi again.

Problems accour when i use System OpenGL driver.

I've selected all other individually (and restarted) and only the System OpenGL driver freezes when in multi-screen - but works when the other screens are removed.

Any suggestions on a fix?

If no fix I will run in emulated Direct 3D 11.


File now attachedlog-file

Not a bug

Looks like your OpenGL driver has issues, please feel free to contact your GPU vendor with this or simply keep using the mode that works for you. The driver you select in settings doesn't really affect the image quality, so D3D emulation is also an option.

Cheers!