0
Answered

Plugin not supported, you have version '3.0.0', expected version is '3.0.6'. - error after update

Eryk 4 months ago updated 4 months ago 4

So after I updated the Origami app to the latest version I can't send the generated file to Illustrator. The error message is exactly as in the title. I tried to update the installation to no success. Could anyone please help me with it?


Windows 10/Illustrator 24.1.2(64-bit)


Answered

This means that the plugin installed into Illustrator is of a different (older) version than Origami itself. By default Origami places a symbolic link into Illustrator folder, pointing to the plugin stored inside Origami folder. This way plugin gets automatically updated when you update Origami. In your case, you probably copied the plugin manually and then after Origami update, it has a different version. Consider copying the new plugin file into the Illustrator's plugin folder, so it has the proper version.

You can check the plugin version by right clicking it and selecting Preferences->Version.

Hello Vitaly! Thanks for your reply. The thing is that all I did was updating Origami when prompted. I didn't copy the plugin manually. I can't check the version the way you told me to since there is no Preferences menu under the right click. I thought that maybe you meant Properties, but even there, I couldn't find the Version.


What I've noticed, is that the .aip file that the shortcut created by Origami in Illustrator folder is pointing to a file that was created 24th of November 2019. Which is weird since all the other files have a creation date of 25th of April 2020. Could you provide me a link to the newest plugin, so I can simply copy it over? I really need this for my work.



You probably updated Origami while having Illustrator running in background, so one of the plugins was not updated (as it was locked by Illustrator). Quit both Origami and Illustrator and re-install the latest Origami. This should do the job.

This indeed solved my issue! Thanks a lot!