Jorien 3 years ago updated by Vitaly Ovchinnikov 2 years ago 13


Since last week the rendering doesn't end. Every time Boxshot stucks on a certain percentage. When I want to cancel the rendering, the software doesn't react and I have to shut it down with ctrl/alt/delete.

I tried to reinstall and I renewed my license, but it doesn't help. I use Boxshot almost every day.

What can I do? Or check?

Kind regards,
Jorien Hanemaaijer

The Netherlands

Under review

Hello Jorien,

It is hard to tell from the description you provided, so far it could be anything from overheating to a software bug. Let's start with your Boxshot version and operating system, also let me know if it happens to a particular scene or to any one? Does it depend on resolution or complexity of the scene?


Hello Vitaly,


Fair point. Ok, there we go:

-   Boxshot version 4.15.1

-          Windows 10

-          First I thought it got stuck, because my license was expired, but I bought a new license yesterday, and it still happens

-          I reinstalled it, but it still happens

-          It happens when I use one of my boxshot files for a 3D book, but also if I make a new one

-          Every time I click Render, the process starts, but on a certain point it just won’t progress. Last Friday everything worked perfectly fine. And fast too. If I wait for half an hour a simple 3D book (width 1000px) is at 28%, for example. Or when I start rendering in the evening, the next morning it is at 96%. Which is weird for a picture with a width of 1000 pixels.

-          If I press ‘Cancel’ it won’t cancel. So I have to quit with control/alt/delete

-          By the way, I use Photoshop and other software at the same time. Which never is a problem when I render small books.


Do you need more information? 


Thanks, two more things:

  1. Is it a laptop or desktop computer?
  2. When you start rendering, there is a window that lets you select resolution and other parameters. One of the parameters is the rendering engine, what engine do you use?

Hi Vitaly,

  1. It's a desktop computer. I work on a virtual desktop.
  2. I always use Raytracer 2. The other option is 'Raytracer (deprecated)'

Kind regards,

Under review

So it gets stuck even if you start with an empty scene and click Render leaving all the settings at defaults? If not, does it stuck if you add a default book into the empty scene and click Render?

Also what is virtual desktop? Is it like remote session or virtual machine?

It does not get stuck when I render an empty scene. But it does stuck (after 73%) when I add a default book (and I don't change the perspective or anything else) and I click render.

I work on a virtual machine (with 2 virtual CPUs and 8GB RAM). I log in on the virtual machine via a remote dekstop. 


Any chance you can try it without virtual machine or without remote desktop or without both on the same hardware?

Does it help to switch to draft rendering mode or to the old deprecated raytracing engine?

Finally, what do you mean by having to shut it down with ctrl/alt/del? Do you restart the whole VM or just kill Boxshot process or what? Does the whole VM stucks or just Boxshot? Or the remote desktop?


I can try it without virtual machine, but can I use the keychain/serial number again?

I tried to render a book with the deprecated raytracing engine: it works! Even 3000px renders quite fast. 

What I meant with ctrl/alt/del: at a certain point Boxshot doens't react to anything. So in order to shut it down I shut down the Boxshot process with ctrl/alt/del (not the whole VM).


That's interesting, please try it without virtual machine and let me know it if works better. You can try the demo version, no need to activate it there.

Hi Vitaly,

It works perfectly fine without the virtual machine. Although I can't make them bigger than 1024px.

That's the limitation of the demo version - it doesn't let you make images more than 1024 pixels. Can you add resources to the virtual machine? More cores in particular?

Also what VM you use?

Hi Vitaly,

We have a new server since last weekend, and 'suddenly' Boxshot is working perfectly fine. So, I want to thank you for all your help and patience.

Have a nice day!

Kind regards, Jorien


No worries :)