0
Fixed

I can't rename a clone Barcode

Eric Balereau 9 months ago updated by Vitaly Ovchinnikov 8 months ago 13

I want to name a EAN 13 model with specific settings with the name of the client I'm using it for.
I clone the EAN-13 1model and try to rename it. Indeed I can type the text I want but it goes back to EAN-13 1 1

Under review

I've just tried to reproduce the problem and everything works just fine. Does it help to restart the app?

Fixed

Try the beta version of Barcode 2 and let me know if you have this problem there: https://boxshot.com/2020/10/14/barcode-2-0.html

Hi Vitaly,

Sorry, it doesn't work for me 

What exactly doesn't work? Some extra details would help.

I can't rename a clone Barcode, same behavior as before.

Under review

Even with the new version? Can you make a video?

good news.It works with new clones.  It didn't work with old clones. Sorry I deleted it before you ask for the video.

One strange behavior in the video at 0:46 maybe the "(" character?

https://ln.sync.com/dl/35af57050/ht5d3ftb-x2jwghiq-3z4mcacv-q264837r

Hm, I can't reproduce that with "EAN-13 VI (refaire)" name - it works just fine here. Could you try that exactly name again and see if it works now? Could you try it a couple of times? Also, when you fail to rename something a couple of times, please click Help->Open System Folder in the main menu and check the log file there for any errors.

Another thing to see is the barcodes folder. Navigate to ~/Library/Application Support/Appsforlife/Barcode/Barcodes where you can find the barcodes you see in the app. Try renaming the same barcode to the same name in Finder. Will it work?

check the log file there for any errors : no error there

Try renaming the same barcode to the same name in Finder : it works

New video

https://ln.sync.com/dl/164f94990/qefg7d3r-8as5gct8-uzhdgg8u-3jmwjtwc

Unfortunately I can't reproduce it. I can't find when and why it happens

That's weird... Could you try three more things, please?

1. If you put exactly the same name many times, will it eventually get renamed?

2. When the problem happens, could you navigate the Finder to the barcodes folder and see if something is really renamed there when you rename it in the application? It most likely doesn't, but still worth double-checking.

3. Again, once it happens, try renaming the same barcode to the same name with Finder in the barcodes folder and see if you get the new name in the application.


In the new video all the answer + a work around (maybe it can even help you understand the problem.
If it's not clear : when I click in another model, the name sticks

https://ln.sync.com/dl/3a8b494c0/ur9pgkgr-kbzthsdc-kbk94mei-hhia7ksv

Planned

Sorry, it took me way too long to realise what's going on :) Try pressing Enter after finishing typing the name and the barcode will get renamed. At the moment Barcode cancels renaming when you click outside of the editor. You're supposed to press Enter or Tab to complete the process. We'll sort it out in the next update.