Under review

Textures exported to 3D different from earlier versions

PBR 9 months ago updated by Vitaly Ovchinnikov 6 months ago 18


I'm having issues importing 3D models in Keyshot.  In earlier versions, when exporting, I'd get different png files for front, back, side, etc... which were then easily taken over in KS.  Now, I get one large file, basically the png version of the AI file, which KS does not recognize and is not applicable as texture in the program.

Would it be possible to re-implement this function?  I think it's a real shame it doesn't work anymore.

Under review

What is the software in question?

Origami (current version)

Under review

Sorry about the late reply.

Both 2nd and 3rd versions of Origami export front, back and side textures of each shape as PNG files. I don't think it really changed between versions and you can compare it for yourself, if unsure. What is the export format you use?

Thx for the reply.  

I have been exporting as collada (.dae) files.  If I'm not mistaken it just adds _foil to the name.  Unfortunately I can't check as I'm on a holiday right now.  I have been having the very same issue in the beginning of the year (with the new version of the software), but then it got pushed to the background because of all the covid stuff.  

It just struck me as I had been able to do that before with no problems.

It would help if you share a simple small exported file, so we can have a look. Collada files can be validated, so it is quite easy to tell if it is correct or not.

Hi, sorry it's been a while bc I was on a holiday.  

I tried to do a simple test.

These are the files I get when exporting my Origami window.

Illustrator 2020-Front.png


Screenshot 2020-08-10 at 14.31.09.png
Screenshot 2020-08-10 at 14.28.43.png
Screenshot 2020-08-10 at 14.27.03.png

These are screenshots.  What .ai file looks like, what the thing looks like in Origami, and what it looks like when I import it in Keyshot.

Well, the file opens well in Boxshot and Koru. I also tried it in Photoshop and it was loaded well:

Could you try the attached file and see if it works better in Keyshot? OrigamiTest_V01_PB_modified.dae

If not, I would contact the Keyshot support and ask why it is not loaded well. Meanwhile, you can try exporting to OBJ format, which might work better.

Also try this file and let me know if it works any better: OrigamiTest_V01_PB_modified2.dae

Thanks for the reply.  I've checked;

First one, same issue.  When imported I just get a blank object.

The second file gives this error:

/Users/pimbraeckevelt/Downloads/OrigamiTest_V01_PB_modified2.dae does not contain 3d geometry.

You may need to export polygonal data from your modeling system.

For additional help please contact support@luxion.com

Well, I would contact their support then with the original exported file or the _modified one (not the _modified2) and ask what exactly is the problem with importing the model. I am almost sure, the problem is on their side.

Hey there PBR and Vitaly, I hope this doesn't come too late - we work extremely closely with Luxion, maker of Keyshot and have worked to develop some new processes together. Since we use Origami (and not Esko who they usually work with) we used our workflow as a use-case for them which may be published at some point in the future. 

In our daily use of Origami and Keyshot we've discovered an issue that no one is sure how to fix, as it seems to be an issue with the DAE format itself, and not something that either company can influence: 

The problem is SPACES. Yes spaces in file names. 

and also PATH LENGTH - 

Here is how you fix: 

You have two options: 

Either save your Illustrator file with NO SPACES and no special characters (e.g. use underscores) 

OR Save a *.ORIGAMI3 file before exporting to DAE (also with NO SPACES) . 

ALSO use only normal characters, e.g. on a Mac you can use / \ in filenames, DON'T DO IT. pretend you're on a PC.

WITH EITHER OPTION - if you save to a network share, try exporting the DAE to a folder on your desktop (to shorten the path length)

Once in Keyshot - check the texture file - you can probably tell in some cases a filename like "long file name.png" is shown as "long" (everything after the space is truncated) and the file doesn't load. You can select the PNG again by RIGHT-CLICKING on the filename and selecting "Replace and retain size" in the menu (do not simpliy replace the file, it won't align properly) 

Now check the results - if the file loads incorrectly, see the Mapping Type: [ UV ] dropdown box, pick planar, then put it back to [ UV ] it should fix it. 

If you save your Illustrator file or .ORIGAMI3 file before exporting, without spaces, you won't run into the issue. 

I hope this helps, 

Vitaly - if you know a way to force filenames to replace spaces with underscores upon export to DAE that would also help. 

Good luck!

Collada format has quite a strict specification and although we are not matching it yet in some areas (working on that), the file I provided above is matching the specification well and still not loading to Keyshot... If the problem is with spaces in file names, can you try this one for me: another-try.zip

I don't think it is illegal to have spaces in file names in Collada, at least I can't find that in the specs. Please feel to forward Luxion guys here, so we can discuss this directly.

I just tested that file and it loads up fine without any adjustment - I don't know that the spaces issue is a universal one, only that removing spaces worked for every team member we have (6 using Origami + Keyshot 9 on Mac). 

This problem is 100% duplicable for us, here is how I just duplicated it right now: 

1. Load up origami and create a Dieline using the generator, send Dieline to illustrator, and add art. 

2. Reload scene Origami to get art from Illustrator
3. Export in origami to .DAE 

 (what was exported)

5. Importing the DAE file file in Keyshot throws an error (I believe this is because I have verbose error logging turned on)

6. In the material texture filename - the filename with spaces was truncated after the first space. 

(notice the word "test" where the full filename should be). 

UPDATE to my previous statement, you have to name the SCENE in Origami with underscores - as well, so that the texture names have no spaces. 

NOW when exported you get this: 

and when imported into keyshot, everything loads perfectly. 

SO long story short, if you could replace all spaces in the exported png filenames, it'd fix the problem. But as a solution for customers in the short term - having them replace spaces in filename and scene name is a way to get it loaded without doing the texture reload per model/side dance. 

Yep, the latest Boxshot should already export like that (without spaces), but it doesn't process the texture paths the same way. As long as the last attached file works for you without issues, such processing should do the job. We'll release this with the next update of both apps, I guess.


Thank you for your messages.  As we have no update license, is there a way to fix this (we have Origami 3)?

Still, it's no major issue, I found that if I relink the texture and press reset in the texture panel (Keyshot 6) it snaps back to its original position.  It took a while to find out, but I'm glad I did.

Try the updated version here: https://boxshot.com/2020/10/24/origami-3-0-10.html

Let me know if it works any better.