Your comments

We have plans for this feature, but it conflicts with our plans to support multiple source documents. We're trying our best to sort this out at the moment. Ideas are welcome :) 

There is a settings window there. On Mac it is under Imposition Wizard menu, on Windows it is under File menu. That's the latest version, the older ones have this in View menu of the running application.

Have a look here for more CSS selectors: https://boxshot.com/support/koru-help/dev_templates.html

You need the koru-viewport one, but once it is defined, Koru will not add its own, so you need to define all the properties there. Something like this should work:

.koru-viewport {
    width: 100%;
    height: 100%;
    position: relative;
    touch-action: none;
    background: transparent;
    margin: auto;
}

You also need to set transparent background in the project itself.

Let me know if it helps.

It should work fine, we never heard of any issues with Mojave.

You will always get z-fighting if two meshes share the same surface. The solution is to make the internal mesh slightly bigger than the space in the bottle, then use materials' priorities to sort this out.

Do you mean the one you save using File->Save Layout menu item? This is a somewhat internal feature and unfortunately there is no way you can send it back to Illustrator.

Got it, thanks. Saving to PSD is currently limited to the Ultimate version only, we'll add it to the Professional version with the next update.


We'll also consider adding output color profile option once switched to the linear workflow.

PSD is just another format option when you saving rendered images. If you don't have one, you probably not using the latest version of Boxshot. Otherwise, please contact us directly as we will need some details.


May I also ask for an example of those "terrible" results when you rendering in CMYK? Boxshot reads CMYK files and their profiles and should convert them to sRGB properly. If the results are terrible because of sRGB - that's at least expected. If not - I would really like to see an example, as this must be fixed.


As for the timeline, we're going to switch to the linear workflow in the upcoming Boxshot 5, but I can't tell you the release date at the moment, as it is still in progress.

Internally Boxshot performs rendering in sRGB, so for all the input files it converts their color profiles to sRGB, then renders a frame and saves it with sRGB profile. Sometimes it is assumed to be sRGB, sometimes sRGB profile is embedded, depending on the format.


This "non-linear" processing is not the best thing we can do, so we're slowly moving to the linear one. For instance Owlet was switched to it recently. The difference is that all the input files are converted to linear space, not sRGB and all the rendering happens there. Then the result is converted back to sRGB.


I understand that this might not be the behaviour that you expect, so let's discuss the best option? Will it help if we offer a list of color spaces to convert to? Or maybe you just need a way to save a linear-space output? For instance in Owlet you can export to EXR or PSD and get a linear floating-point image that you can convert to whatever color space you want without losing any details. Assuming we have a linear-processed buffer of floating point RGB colors, what can we do to export it the best way?


Btw, Boxshot supports transparency in PNG, TIFF and PSD output formats.

Can you click File->Collect Resources in the menu, then pack the whole folder and send it here? This way we get it exactly as you have it. Sending just a project doesn't help, as it may contain other stuff. 


Thank you.